XT IDE Build/Install
Mon Mar 09, 2020 3:16am

So, last month I was able to get in contact with the guy at Glitchworks and pick up an XT IDE parts kit. He's no longer making the cards/kits but was kind enough to still let me buy one from him.

I'm not great at soldering, I've done it a bunch in the past but assembling a whole IDE board was definitely the most advanced and largest single solder job I've done. All in all, it only took a little over an hour and it actually worked when I was done. (Thank god!)

Card assembled. I had to use an LED I had floating around. The parts kit was missing one. You can see my second XT partially disassembled in the background. It was nice having a second computer to try things on before taking apart the computer it was going to be installed on.

Solder job on the back. Not too terrible for being a novice.

These next two pics are the "default" values for the dip switch settings. I got them off of

Back of "good" XT installed. (I used my "parts" XT for testing as it had more open ISA slots and was already mostly disassembled). The inside of the case is super cramped now between the FDD cables, MFM cables and now IDE cables. Every ISA slot is taken up except the one to the left of the modem (it has a daughter board on it with it's own 12mhz cpu.. no idea what that does but it makes it impossible to use the slot next to it) and the famous slot 8. The XT IDE can actually use slot 8 if you add in an additional ROM chip and set some jumpers.

I went 256MB CF card because I knew from my 486, I couldn't use more than 504MB of it and I can't imagine ever getting close to using 256MB on an XT.

Front view all assembled just for kicks:

So, when you boot, it goes through the slow count up of the RAM (512KB in my case) then does a floppy drive/HDD seek before entering into the XT IDE menu. I haven't tried booting from a floppy before it hits the menu but it will not boot to the hard drive until one of the options in the menu is picked. Which is nice for reasons I'll put down later in this post.

XT IDE BIOS auto detects everything. It's amazing. It detects all the drives and even other drives if you add them. I plugged in an IDE drive and it worked flawlessly without having to do any configuration. (No settings sectors, heads, etc)

360Kb drive:

It calls the original MFM hard drive as a "foreign drive" probably because it's controlled by another ISA card. Still knew the capacity though which was pretty wild!

256CF card. Auto configured as well as has the manufacturer name already filled out. When I had the IDE drive in there, it knew it was a Maxtor as well.

Booting to CF card. I'm undecided if I want to keep DOSKey installed. It's very useful but also eats up some of the 512KB of RAM.

Directory listing on the CF card. The first "dir" command takes a while to complete as it calculates the 256MB free space. It's slow on a 20MB drive... just imagine that multiplied by 10. Good thing is that it only does it once per boot from what I can tell.

Another awesome thing that I was really surprised about is that the original MFM drive is auto-configured as drive D:! So, even though the computer is booted off the CF card it can still access the files on the MFM drive.

Gotta love the slow image fade on the IBM monochrome monitors. :)

Booting to the original MFM hard drive. Selecting the old hard drive in the menu boots the computer just as if the XT IDE wasn't there.

One of the good reasons that it doesn't automatically boot to the hard drive before going to the XT IDE menu is that from the MFM drive, you can't see the IDE drives attached to the XT IDE card. So if it were to auto-boot, accessing the IDE device would be impossible.

Example from booting to the MFM drive:

All in all, I'm super happy with this card. They're surprisingly harder to track down than I thought they would be. I figured I would be able to find them floating around everywhere but that doesn't seem to be the case. Now both my 486 and XT are compact flash, I hopefully don't have to worry about the inevitable hard drive death of the original 20-30 year old hardware. I actually tried to hook up one my 486 drives that was working before I switched it to CF a few months ago and it refuses to boot. It was already sounding funny when I swapped to a CF card, I can't imagine how much stuff I would have lost if I didn't switch over when I did.

My XT's hard drive was already brought back from the dead after unsticking the head and replacing the resistor that popped on the hdd controller board. In my mind, it's already on it's last legs at this point (the drive, not the computer). Good news is I was able to copy all the files from the MFM drive to the CF drive without a single error reading the data. I was surprised about that. It looks like the XT IDE handles reading/writing to the CF cards better than the internal HDD controller on my 486.

Anyway, I guess that's the end of my long ramble-y post. :D

Edit: I have to double check with my second XT, but I think something odd is going on with my graphics card. It causes the DOS prompt to hover in the middle of the line instead of at the bottom. It's sort of off putting typing with the cursor indicator located at a little lower than the cross section of the letter "t". Other than the prompt, the rest of the functionality seems normal though.

Here's what the inside of the case looks like with everything in there to give an idea of how cramped it is.

    • Soldering looks good. - Puckdropper, Wed Mar 18 2020 12:20am
      Wow, that's so awesome! I wonder if my XT would even boot. I got a similar device for the Apple II, but it was professionally built. Nice to not have to worry about magnetic rot.
      • Thanks! - Erik_, Wed Mar 18 2020 2:03am
        You should try to boot your XT, you might be surprised. Before this year, the last time I tried booting either of mine was around 2011. Before that was probably mid-2000s. The spare one worked for a bit unaltered. The hard drive on it has trouble spinning up even after lubing the motor and unstic... more
        • I should get those old computers up and going - Puckdropper, Sat Mar 21 2020 5:12pm
          I've sorta got an AT, too. It was a build rather than a full AT. It's not good to let them sit for so long. I think the CFFA card, which is what mine is, has a menu so you can select the program you want. Some (apparently many) programs played tricks with the disk, so it also gives you an opti... more
          • computers. It's a fun nostalgia trip going back and working on them. On the one hard drive I found a text document from 20 years ago that I wrote when I first got my Leading Edge Model D XT clone. That was cool to stumble upon. Life has a way of just flying by and then next thing you know it's "... more
            • My AT is a MB and case - Puckdropper, Fri Mar 27 2020 12:27am
              I'm pretty sure it was never an AT-286, just another 8088-class CPU. Man, those things have less power than a PIC and still managed to run an entire disk operating system! (With lots of help, of course.) Someone suggested that capacitors need time to "reform" or basically be powered up occasion... more
              • I thought all IBM ATs were 286s? - Erik_, Wed Apr 01 2020 10:53am
                I never owned one, just going off what's bouncing around in my head (never a good idea). Yeah the through hole caps are nice and easy to replace and usually have the writing on it exactly what you need to replace it with. I haven't tried doing a surface mounted component yet.. If I ever get back ... more
                • Maybe it is. It's been a while! - Puckdropper, Thu Apr 02 2020 4:03pm
                  I don't remember the X1541 being particularly slow, but I was running it with a 386 at the time, so everything was slow! IIRC, there was a program called X1541 that only transferred data from floppy diskette to PC, then there was a C64 emulator that you could run and I don't remember it's name. ... more
    • Benchmark Oddity - Erik_, Mon Mar 09 2020 11:04am
      I'm not sure how clear it is in the image, but the benchmark program I tried on the XT is showing that the CPU is only actually running at 2.47MHz? It has the correct 8088 processor and speed listed. Maybe I'm reading it wrong and that's just giving the chart version of "This is running like a... more
  • Click here to receive daily updates
    "Forces act when not restrained" - Puckdropper